We have been working of late to fix a number of issues with DYMO label printing and Google Chrome. The last outstanding issue was resolve two weeks ago when using the latest DYMO software (8.6.1).

That was until the past week when Google released version 58 of Chrome. A change in this latest version stopped Chrome from being able to talk with DYMO printers. We have spoken with DYMO about this and are expecting they will release a new version of their software late next week to resolve the issue. In the meantime, they have given DYMO users two options to get their label printers working again.

1. Use Firefox, Safari or Edge.
2. Type chrome://flags/#allow-insecure-localhost into the Chrome address bar and enable the allow-insecure-localhost setting, this will allow Chrome to talk with DYMO label printers. Please restart Chrome so the setting takes effect. Chrome will display Not Secure in the address bar, but only the link between Chrome and a DYMO printer is insecure, no other info is insecure or at risk.

We will post back here again once DYMO releases the update for their software. Please email support@ucarehq.com if you have any questions or need help getting your printers working.